Innovasys RealWorld Sample Booklet

This booklet provides a brief introduction to the Innovasys Real World sample application.
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2 Welcome to Innovasys RealWorld

RealWorld is a sample application built as a demonstration of HelpStudio functionality, including context
sensitive help and dynamic help.

This help file contains a number of Topics, images, a Booklet definition, a number of Build Flags and 2 Build
Flags. The Build Flags and the 2 Build Profiles are included to illustrate how you can generate multiple
outputs from a single project. Use is made in several topics of the HelpStudio Dynamic Image, Drop Down
Section and Note Box Widgets (this topic contains a Dynamic Image Widget and a Drop Down Section
Widget).
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Functional Overview

The RealWorld sample application includes the following areas of functionality:
Customers
Adding a customer (Section 6.1)

Editing a customer (Section 6.2)

Deleting a customer (Section 6.3)

Employees

Adding an employee (Section 7.1)
Editing an employee (Section 7.2)

Deleting an employee (Section 7.3)
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Products

Adding a product (Section 8.1)
Editing a product (on-line documentation)

Deleting a product (Section 8.3)

Suppliers

Adding a supplier (Section 9.1)
Editing a supplier (Section 9.2)

Deleting a supplier (Section 9.3)

Orders

Adding an order (Section 10.1)
Editing an order (Section 10.2)

Deleting an order (Section 10.3)

Categories

Adding a new category (Section 12.1)
Editing a category (Section 12.2)

Deleting a category (Section 12.3)

Shipping

Adding a new shipper (Section 13.1)
Editing a shipper (Section 13.2)

Deleting a shipper (Section 13.3)

Scribble

Changing the line color (Section 14.1)

Changing the line width (Section 14.2)
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3 The RealWorld User Interface

The RealWorld user interface consists of several areas, outlined below:
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Standard toolbar Contains common action buttons and shortcuts to RealWorld views

Browser toolbar Contains commands for working with the RealWorld browser

e Shortcuts Displays a list of views and Internet shortcuts
o Dynamic help Displays context help on the current view

Workspace Displays the current view, it could be a browser page, or a data entry window
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4  Opening Views
RealWorld has several core views and a basic browser interface. All core features can be accessed by the

Shortcuts window displayed on the left hand side of the RealWorld user interface.

To open, simply click the corresponding node in the shortcuts treeview. If the window is not currently open, or
has been closed, it will be opened. If it is already open, then it will be activated.

Clicking a internet shortcut will open/activate the browser window and display the specified page. Only one
browser window can be open at any one time.

Displaying a list of open windows
e Open the Window menu. A list of the first 10 open windows will be listed.
- or -

1. Open the Window menu and click More Windows.
2. The dialog displayed will list all open windows, allowing you to easily view and switch between windows
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5 Views

5.1 The customers view

’3 The Customers view displays a list of all your customers, and provides access for adding, editing
or removing them.

5.2 The employees view

3} The Employees view displays a list of all your employees, and provides access for adding, editing
or removing them.

5.3 The products view

=K The Products view displays a list of all your products, and provides access for adding, editing or
removing them.

5.4 The suppliers view

The Suppliers view displays a list of all your suppliers, and provides access for adding, editing or
removing them.

5.5 The orders view

The Orders view displays a list of all your orders, and provides access for adding, editing or
removing them.

5.6 Browser

The browser window allows you to view local or remote web pages

©2016 My Company. All Rights Reserved.




Getting Started

6 Customers

6.1 Adding a customer

1. Display the customers view (Section 5.1) and click the Add button.

6.2 Editing a customer

1. Display the customers view (Section 5.1) and select a customer from the list
2. Click the Edit ||z button.

6.3 Deleting a customer

1. Display the customers view (Section 5.1) and select a customer from the list
2. Click the Delete [¥| button.
3. Answer Yes to the confirmation prompt to remove the record.

Please note that removing a customer will not remove any related orders or modify other records
linked to that customer.
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7 Employees

7.1 Adding an employee

1. Display the employees view (Section 5.2) and click the Add button.

7.2 Editing an employee

1. Display the employees view (Section 5.2) and select an employee from the list
2. Click the Edit ||z button.

7.3 Deleting an employee

1. Display the employees view (Section 5.2) and select an employee from the list
2. Click the Delete [¥| button.
3. Answer Yes to the confirmation prompt to remove the record.

E Please note that removing an employee will not remove any related orders or modify other
records linked to that employee.
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8 Products

8.1 Adding a product

1. Display the products view (Section 5.3) and click the Add button.

8.2 Editing an employee

1. Display the employees view (Section 5.2) and select an employee from the list
2. Click the Edit ||z button.

8.3 Deleting a product

1. Display the products view (Section 5.3) and select a product from the list
2. Click the Delete [¥| button.
3. Answer Yes to the confirmation prompt to remove the record.

Please note that removing a product will not remove any related orders or modify other records
linked to that customer.
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9 Suppliers

9.1 Adding a supplier

1. Display the suppliers view (Section 5.4) and click the Add button.

9.2 Editing a supplier

1. Display the suppliers view (Section 5.4) and select a supplier from the list
2. Click the Edit ||z button.

9.3 Deleting a supplier

1. Display the suppliers view (Section 5.4) and select a supplier from the list
2. Click the Delete [¥| button.
3. Answer Yes to the confirmation prompt to remove the record.

E Please note that removing a supplier will not remove any related orders or modify other records
linked to that customer.
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10 Orders

10.1 Adding an order

1. Display the orders view (Section 5.5) and click the Add button.

10.2 Editing an order

1. Display the orders view (Section 5.5) and select an order from the list
2. Click the Edit ||z button.

10.3 Deleting an order

1. Display the orders view (Section 5.5) and select an order from the list
2. Click the Delete [¥| button.
3. Answer Yes to the confirmation prompt to remove the record.
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11 Reference

11.1 CommandBar Reference
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F1

Ctrl+A
Ctrl+E
Ctrl+D
Ctrl+P
Alt+F4

F1

Ctrl+A
Ctrl+E
Ctrl+D

Ctrl+P

Alt+F4

Displays a preview of the printed output

Displays the help file for Innovasys RealWorld
Displays the RealWorld default page

Displays the previous page in the browser history
Displays the next page in the browser history
Adds a new record

Edits the selected record

Removes the selected record

Send feedback on RealWorld to Innovasys

Prints the contents of the current window

Quit Innovasys RealWorld

.2 HotKeys Reference

Displays the help file for Innovasys RealWorld
Adds a new record

Edits the selected record

Removes the selected record

Prints the contents of the current window

Quit Innovasys RealWorld
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12 Categories

12.1 Adding a new category

1. From the Tools menu, click Categories
2. Click the Add @ button to add a category
3. Click OK to save your changes

12.2 Editing a category

. From the Tools menu, click Categories

. Select the category you want to edit

. Optional. To rename a category, press F2 and enter the new name.

. Optional. To change the description of the category, press Enter and enter the new value

. Optional. To change the image associated with a category, click Select Image and choose a new graphic.
. Press OK to save your changes.

o U WN =

12.3 Deleting a category

1. From the Tools menu, click Categories

2. Click the Delete |Z| button.

3. Answer Yes to the confirmation prompt to remove the record.
4. Click OK to save your changes

Please note that removing a category will not update any products linked to this category.
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13 Shipping

13.1 Adding a new shipper

1. From the Tools menu, click Shipping
2. Click the Add @ button to add a shipper
3. Click OK to save your changes

13.2 Editing a shipper

. From the Tools menu, click Shipping

. Select the shipper you want to edit

. Optional. To rename a shipper, press F2 and enter the new name.

. Optional. To change the phone number of the shipper, press Enter and enter the new value

. Optional. To change the image associated with a shipper, click Select Image and choose a new graphic.
. Press OK to save your changes.
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13.3 Deleting a shipper

1. From the Tools menu, click Shipping

2. Click the Delete |Z| button.

3. Answer Yes to the confirmation prompt to remove the record.
4. Click OK to save your changes

Please note that removing a shipper will not update any orders linked to this shipper.
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14 Scribble Pad

14.1 Changing the line color

Open the drop down color list and select a new color

14.2 Changing the line width

Adjust the slider from left to right. The further to the ride the slider is, the thicker the line will be
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15 Browser

15.1 Moving back in the history list

In the Browser toolbar, click Back

15.2 Moving forward in the history list

In the Browser toolbar, click Forward
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16 Index

ActiveX, 3-4
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Browser, 7
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Categories
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Category
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Changing the line color, 16
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Concept application, 3-4
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Customer
Adding, 8
Deleting, 8
Editing, 8
Viewing, 7

Customers

Adding a customer, 8
Deleting a customer, 8

Editing a customer, 8

Customers View, 7
Deleting a category, 14
Deleting a customer, 8
Deleting a product, 10
Deleting a shipper, 15
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Deleting an employee, 9
Deleting an order, 12
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Employee

Adding, 9
Deleting, 9
Editing, 9
Viewing, 7

Employees

Adding an employee, 9
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Deleting an employee, 9

Editing an employee, 9

Employees View, 7
Forwards, 17
Getting Started

Opening Views, 6

Hot Keys, 13

HotKeys Reference, 13

Innovasys, 3-4

Innovasys RealWorld Sample Booklet, 0
Keyboard, 13

Line, 16, 16

List, 6
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Opening Views, 6

Order

Adding, 12
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Editing, 12
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Orders
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Deleting an order, 12
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Overview, 5

Page, 7
Product

Adding, 10
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Delete, 10
View, 7

Products
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Adding, 11
Deleting, 11
Editing, 11
Viewing, 7

Suppliers

Adding a supplier, 11
Deleting a supplier, 11
Editing a supplier, 11

Suppliers View, 7

The customers view, 7

The employees view, 7

The orders view, 7

The products view, 7

The RealWorld User Interface, 5

The suppliers view, 7

User Interface, 5
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Welcome, 3-4

Welcome to Innovasys RealWorld, 3-4
Width, 16

Window, 6
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